Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 314
» Latest member: Cromaglious
» Forum threads: 440
» Forum posts: 3,762

Full Statistics

Online Users
There are currently 22 online users.
» 4 Member(s) | 18 Guest(s)
darkhelmet02, Irinikus

Latest Threads
Your first SGI encounter?
Forum: SGI Discussion
Last Post: Cromaglious
8 hours ago
» Replies: 40
» Views: 2,062
My first animation projec...
Forum: Art/CG/Rendering
Last Post: bjames
9 hours ago
» Replies: 6
» Views: 131
The Universe in Maya
Forum: Art/CG/Rendering
Last Post: bjames
9 hours ago
» Replies: 16
» Views: 575
A true show of the Tezro'...
Forum: SGI Discussion
Last Post: bjames
9 hours ago
» Replies: 2
» Views: 86
1080 resolution octane mx...
Forum: Beginners' Questions/Tips
Last Post: bjames
9 hours ago
» Replies: 16
» Views: 506
The SUN Microsystems V880...
Forum: Sun/ORACLE/Fujitsu
Last Post: Irinikus
Yesterday, 07:12 PM
» Replies: 80
» Views: 3,038
Newbie just starting on t...
Forum: Beginners' Questions/Tips
Last Post: gijoe77
Yesterday, 03:22 PM
» Replies: 5
» Views: 206
help with nettle gmake ch...
Forum: Development/Porting
Last Post: mrthinlysliced
Yesterday, 06:23 AM
» Replies: 11
» Views: 151
Just how loud is a V880z?
Forum: Sun/ORACLE/Fujitsu
Last Post: commodorejohn
Yesterday, 03:06 AM
» Replies: 3
» Views: 111
ipv6 and localhost
Forum: IRIX/Software
Last Post: dexter1
09-18-2018, 09:52 PM
» Replies: 0
» Views: 32

 
  ipv6 and localhost
Posted by: dexter1 - 09-18-2018, 09:52 PM - Forum: IRIX/Software - No Replies

While tracking down regressions in the new curl compile on my ChallengeS with IRIX 6.5.22m and enabled IPV6 i came across this:

Code:
cyane:/# ping localhost
PING localhost (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=255 time=1.007 ms
works,

Code:
cyane:/# ping -6 ::1
PING ::1 (::1): 56 data bytes
64 bytes from ::1: icmp6_seq=0 ttl=255 time=1.808 ms
works also,

Code:
cyane:/# ping -6 localhost
ping: localhost: Non-recoverable failure in name resolution
this doesn't work.

Now this is because most likely the /etc/hosts file doesn't have an ::1 entry which points to localhost (or ipv6-localhost, ip6-localhost or even ip6-loopback) so i added it, but even after that it still can't resolve localhost to ::1 when specifying ipv6 protocol. I guess i am missing something in terms of syntax in /etc/hosts or an extra options in /etc/nsswitch.conf
I do have route6d running, but not routed.

Anyone who has an ipv6 configuration with 'ping -6 localhost' working on their IRIX boxes, preferably with 6.5.22 OS?
If you do, let me know.

Print this item

  A true show of the Tezro's performance!
Posted by: Irinikus - 09-17-2018, 06:43 PM - Forum: SGI Discussion - Replies (2)

Today I thought that I'd try and break my Tezro by loading it as much as was reasonably possible and ended up by coming off second best!

It actually performed way better than expected!

Just for the record, there are 7 instances of power flip and Atlantis running in the video, I picked this up after the fact! (Shame on me!)



I'm fully aware that if you truly want to measure a machine's performance, then you just measure the time it takes to render a complex scene using a program such as Maya.

This would be like watching paint dry, hence the method that I used in this video. One thing that's blatantly apparent is this machines' incredible ability to perform context switches.

Print this item

  My first animation project
Posted by: 55cancri - 09-16-2018, 06:48 PM - Forum: Art/CG/Rendering - Replies (6)

Hello,

I now have finally finished my first animation video ... it took months and was a hell of a work for me, but I paused the work a lot and the visual quality is comparable to that what you can see on the Nintendo 64. The Video is about the Steamed Hams meme, there are tons of those videos in a million variations on youtube. So I made a variation (in german language) that plays in the videogame Turok - Dinosaur Hunter for the N64. This game and Mario 64 was the first three dimensional thing I played back then, so it had a huge impact on me.

I used an Octane2 for all rendering and animation - single CPU with 400MHz, a VPro 10 and 2,5GB RAM. The software I used was Maya 6.5. I had very little experience with all that before I got into SGI computers. I played a little with Truespace 3D for Windows as a kid 20 years ago, for this animation I had to learn everything from scratch, with some books I ordered, google and youtube tutorials.

Man, I'm so glad it's done Cool

https://youtu.be/n0I0XcLrUXs

Print this item

  Samba
Posted by: JacquesT - 09-16-2018, 03:43 PM - Forum: IRIX/Software - Replies (2)

Does anybody have any [simple] guides on setting up Samba on Irix? I've installed neo_samba and all it's required reps, I just need the Octane to connect as a client to my samba share on my RasPi. There seems to be an awful lot to install and configure...?

Print this item

  help with nettle gmake check
Posted by: gijoe77 - 09-16-2018, 06:52 AM - Forum: Development/Porting - Replies (11)

so I have two questions actually if someone can shed some light.  I noticed when I compiled gmp-6.1.2 the "gmake check" scripts had a "-lgmp" flag for linking the gmp libraries, and now that I'm working with nettle-3.4 I'm noticing "-lnettle" flags.

so question 1:  how do these library flags work?  do I need to do something special for "-lgmp" or "-lnettle" to somehow now work?  They are clearly not part of MIPSPro, is this some sort of gcc-ism?  If they are in my lib path are they somehow now recognized?


Why am I doing this?  I wanted to compile wget, but it said it wanted gnutls, gnutls wants nettle, nettle wants gmp. so here I am.

question 2.  when doing the "gmake check" for nettle, I get:


Code:
gmake[1]: Entering directory `/usr/people/develop/dev/nettle/nettle-3.4/testsuite'
/usr/bin/cc -c99 -g0 -woff all -O2 -mips4 -L..  pss-mgf1-test.o testutils.o ../nettle-internal.o  -lnettle  -o pss-mgf1-test
ld32: ERROR   33 : Unresolved text symbol "nettle_pss_mgf1" -- 1st referenced by pss-mgf1-test.o.
        Use linker option -v to see when and which objects, archives and dsos are loaded.  
ld32: INFO    152: Output file removed because of error.
gmake[1]: *** [pss-mgf1-test] Error 2

i tried putting "-lnettle" after basically everything, but I'm not clear how this "-lnettle" is supposed to work, if work at all, and wtf is this about a program that cant resolve its own symbols?  Isn't that the point of compiling this program in the first place?  why does it seem like a catch 22?  "sorry, cant compile A because part-of-A is missing"

can someone help shed some light for me?

edit:

just to piggy back off this topic, I did a "gmake install" and everything went fine.  It for some reason installed everything into /usr/local/lib32 rather than /usr/local/lib, but that's ok, I copied everything over to /usr/local/lib

I tried to move on and build gnutls, and it complained:


Code:
./configure --prefix=/usr/local

<snip>

checking for NETTLE... no
configure: error: 
  ***
  *** Libnettle 3.4 was not found.

after I installed nettle, it doesn't seem these newer configure scripts can find it - any insight would be fabulous

Print this item

  irisware Bitbucket - commit your patches and build notes
Posted by: Raion - 09-16-2018, 12:56 AM - Forum: irisware - No Replies

Greetings!

Our bitbucket for patches and notes is now live. We'll be using this also for bootstrap scripts. If you have anything to commit you can request write access to the repo, if you're well known and trusted. Otherwise reach out to me or someone else handling it.


https://bitbucket.org/projectkitsune/irisware

Print this item

  can't seem to install gmp 6.1.2?
Posted by: gijoe77 - 09-15-2018, 09:50 PM - Forum: Development/Porting - Replies (4)

ok so I am baffled!  I compiled gmp-6.1.2, "gmake check" passed, but I can't install it, "gmake install" is failing.  Here are the details:


Code:
export CC=cc
export CXX=CC
export CFLAGS="-c99 -g0 -O2 -mips4"
export CXXFLAGS=" -g0 -O2  -mips4"


./configure --prefix=/usr/local
gmake

<snip> # no errors

gmake check

<snip> # All tests pass

gmake install

<snip>

 ./install-sh -c -d '/usr/local/lib'
 /bin/ksh ./libtool   --mode=install /usr/bin/install -c   libgmp.la '/usr/local/lib'
libtool: install: /usr/bin/install -c .libs/libgmp.so.11.2 /usr/local/lib/libgmp.so.11.2
/usr/bin/install: can't open libgmp.so.11.2: No such file or directory.
gmake[3]: *** [install-libLTLIBRARIES] Error 2


so its failing on the line "/usr/bin/install -c .libs/libgmp.so.11.2 /usr/local/lib/libgmp.so.11.2"

the file " .libs/libgmp.so.11.2" is there and is readable, and I can actually just use "cp" to copy it, I tried to edit the Makefile but its a bit too confusing to me atm, it seems there is a list of files it is processing and I'm still trying to get this libtool thing sorted.  Anyone have any ideas why the copy is failing?  Here is some more info on the file in question:


Code:
-bash-4.2# file .libs/libgmp.so.11.2
.libs/libgmp.so.11.2:   ELF N32 MSB mips-4 dynamic lib MIPS - version 1

-bash-4.2# ls -la .libs/libgmp.so.11.2
-rwxr-xr-x    1 develop  user      1010632 Sep 14 10:09 .libs/libgmp.so.11.2

-bash-4.2# /usr/bin/install -c .libs/libgmp.so.11.2 /usr/local/lib/libgmp.so.11.2
/usr/bin/install: can't open libgmp.so.11.2: No such file or directory.

Print this item

  Trig input.
Posted by: uunix - 09-15-2018, 10:02 AM - Forum: Hardware/Triage/Repair - Replies (1)

I notice on many video input cards, like my own Digital Video board, there is an undocumented (as far as I know) BNC input labelled 'TRIG'

It's never mentioned in any docs.. anyone know what it is?

Oh I say 'any docs' what I mean is the docs I've read for installing etc.

Print this item

  Just how loud is a V880z?
Posted by: Irinikus - 09-13-2018, 08:02 PM - Forum: Sun/ORACLE/Fujitsu - Replies (3)

I made this video to give you a noise comparison between this monster, the SGI Tezro and the Mac Pro 2013.

For those of you who think that the Tezro's loud, take a listen to this:

Note that the V880z's noise output reduces significantly once the operating system comes up, so what you're hearing here is the reduced noise output from this monster!

Print this item

  CD Burner for Octane
Posted by: bjames - 09-13-2018, 05:12 PM - Forum: Hardware/Triage/Repair - No Replies

Anyone recommend a CD burner capable of writing ISO9600 data to CDs that can be opened in windows?

Print this item