Blender 2.45 : a powerful 3D tool for your SGI (edit : and yet 2.48a works)
#11
RE: Blender 2.45 : a powerful 3D tool for your SGI (edit : and yet 2.48a works)
Thanks Raion Smile 

I will try this version.
Could you confirm me it doesn't matter uninstalling my older version of GCC ?

----------

During this time, I start my 3D project.
The first thing to do is to remember all the subtleties of scan line rendering in Blender and optimizing render times to be the most efficient.
My 12K 1x400 is not to bad !

[Image: blender_2-48e_sc01.jpg]

———————————————————————————————
Nevermind if SGI is dead ... In SGI I trust (^_^!)

Octane 1x400Mhz / 2Go Ram / V8 / Irix 6.5.26
def13
O2

Posts: 36
Threads: 5
Joined: Jun 2018
Find Reply
11-21-2018, 10:26 PM
#12
RE: Blender 2.45 : a powerful 3D tool for your SGI (edit : and yet 2.48a works)
(11-21-2018, 10:26 PM)def13 Wrote:  Thanks Raion Smile 

I will try this version.
Could you confirm me it doesn't matter uninstalling my older version of GCC ?

----------

During this time, I start my 3D project.
The first thing to do is to remember all the subtleties of scan line rendering in Blender and optimizing render times to be the most efficient.
My 12K 1x400 is not to bad !

[Image: blender_2-48e_sc01.jpg]

If you're using the freeware GCC then uninstalling it isn't necessary, just ensure you set CC variable to the neko_gcc.

I'm the manager
Besides IRIX Network, I run these sites:
projectkitsune.com

Tezro
Origin 2000 Deskside
Octane2
Indigo2 IMPACT
Indigo2
 O2
3x Indy

Raion
Operator
*******

Posts: 360
Threads: 70
Joined: Nov 2017
Website Find Reply
11-21-2018, 11:08 PM
#13
RE: Blender 2.45 : a powerful 3D tool for your SGI (edit : and yet 2.48a works)
uninstalling any sort of freeware wont impact the irix system, but as Raion is saying, you can change your CC variable and point it to the nekoware gcc.  I personally think your better off moving freeware to the very end of your path variable, that way the newer nekoware version of gcc always gets used, but you can still have the older one on your system if needed for some reason.

for example, say you install nekoware gcc, you want that nekoware in your path before freeware, so your $PATH variable would be something like:


Code:
setenv PATH /usr/local/bin:/usr/nekoware/bin:/usr/sbin:/usr/bsd:/sbin:/usr/bin:/usr/bin/X11:/usr/freeware/bin


or 


Code:
export PATH=/usr/local/bin:/usr/nekoware/bin:/usr/sbin:/usr/bsd:/sbin:/usr/bin:/usr/bin/X11:/usr/freeware/bin

this of course depends on the shell you use and you can put that into your ~/.login or ~/.profile or ~/.bashrc or whatever file to set it automatically when you log in.

last time I build python2 here was the environment I setup (using bash shell):

Code:
export CC=gcc
export CXX=g++
export CFLAGS="-std=gnu99 -g -O1 -mips4"
export CXXFLAGS="-g -O1 -mips4"
export CPPFLAGS="-I/usr/local/include -I/usr/local/include/openssl -I/usr/local/include/ncurses -I/usr/nekoware/include"
export LDFLAGS=" -L/usr/local/lib -L/usr/local/lib32 -L/usr/nekoware/lib -lssl -lcrypt -lcurses -ltermcap"
export LD_LIBRARYN32_PATH=/usr/local/lib:/usr/local/lib32:/usr/nekoware/lib

./configure --prefix=/usr/local
gmake
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
11-22-2018, 09:37 AM
#14
RE: Blender 2.45 : a powerful 3D tool for your SGI (edit : and yet 2.48a works)
Thanks all helping me to solve this compiling problem …
I've uninstalled fw gcc with the Software Manager (not the original 'gcc' located in /usr/local/…)
I've installed neko_gcc43_core-4.3.1.tardist (with all dependences)
I use c shell ; so, I configure .schrc like that :

Code:
# for ./configure
setenv CC gcc
setenv CXX g++

I took care to having listed in PATH  /usr/nekoware/bin:/usr/nekoware/gcc43/bin
I made all of this with my root accompt

But I have got the same error.
I'm sure I miss something and an "Unix power user" could solve it in a minute … I'm just a "level 1 Padawan" Big Grin 

Instead of being stop by this, I continue to work on my mograph project. This turns arround the Silicon Graphics logo (one of the most beautiful logo I've ever seen … so far !).

As you will see, I work on a retro shinny chrome aspect (80's style) … Yes, I work with retro PAL format (720x576).
Modeling, compositing and rendering strictly made with Blender 2.48a on my Octane R12K 1x400 Mhz - render time ≈ 03h07m30s (01m15s / frame)

Enjoy Smile 




[Image: blender_2-48a_logo-sgi_part01.jpg]

———————————————————————————————
Nevermind if SGI is dead ... In SGI I trust (^_^!)

Octane 1x400Mhz / 2Go Ram / V8 / Irix 6.5.26
def13
O2

Posts: 36
Threads: 5
Joined: Jun 2018
Find Reply
11-25-2018, 05:33 PM
#15
RE: Blender 2.45 : a powerful 3D tool for your SGI (edit : and yet 2.48a works)
the project looks great!

btw can you compile a "hello world" program? the error your still getting is the "ar" issue?
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
11-25-2018, 11:20 PM


Forum Jump:


Users browsing this thread: 1 Guest(s)