Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
#1
Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
Currently have an Indy running IRIX 6.5,

I have been trying to install MIPSPro, GCC, and G++ with no luck.


I have had a conflict in MIPSPro with a "dev.sw.lib" and I was curious if anyone knew where that comes from?

Has anyone had success just building the nekoware gcc and g++ compilers?  This way I wouldn't have to do this.
I have those installed, but I am not sure if I have to do any redirecting, or pointing to the locations of install to compile.

Any help/insight would be appreciated!
Best,



James Indy
zygal Offline
Indy

Posts: 14
Threads: 2
Joined: Jun 2018
Find Reply
09-27-2018, 02:17 PM
#2
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
what version of MIPSpro are you trying to install?

You need to make sure you have development foundations and development libraries installed. For newer MIPSpro (which you should install) you will need development foundations 1.3. Its on the ftp.

Once you have that installed I assume you shouldn't have a problem installing nekoware's gcc (both 3.4.6 and 4.7.1)
gijoe77 Offline
Tezro

Posts: 349
Threads: 23
Joined: Jun 2018
Find Reply
09-27-2018, 02:29 PM
#3
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
MIPSpro 7.4.4 is the one I have. I think I may have development foundations 1.3. I will try and do that tonight then.

Thanks for the suggestions!
Best,



James Indy
zygal Offline
Indy

Posts: 14
Threads: 2
Joined: Jun 2018
Find Reply
09-27-2018, 02:31 PM
#4
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
You need development foundation 1.3 and development libraries 1.3 products, there are each on separate CD's.
dexter1 Offline
Global Moderator
******

Posts: 129
Threads: 8
Joined: May 2018
Find Reply
09-27-2018, 03:16 PM
#5
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
dexter1, thanks for clarifying that. I will have to try installing both then!

I am assuming development libraries 1.3 products are available via the ftp, correct?
Best,



James Indy
(This post was last modified: 09-27-2018, 03:43 PM by zygal.)
zygal Offline
Indy

Posts: 14
Threads: 2
Joined: Jun 2018
Find Reply
09-27-2018, 03:42 PM
#6
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
it appears they might be (the libraries doesn't have a version number tho).

I see /irix-os/devel/developmentlibraries.tar.gz and /irix-os/devel/mipspro-74/devf_13.tar.gz on the ftp
gijoe77 Offline
Tezro

Posts: 349
Threads: 23
Joined: Jun 2018
Find Reply
09-27-2018, 03:55 PM
#7
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
(09-27-2018, 02:29 PM)gijoe77 Wrote: what version of MIPSpro are you trying to install?

You need to make sure you have development foundations and development libraries installed.  For newer MIPSpro (which you should install) you will need development foundations 1.3.  Its on the ftp.

Once you have that installed I assume you shouldn't have a problem installing nekoware's gcc (both 3.4.6 and 4.7.1)

(09-27-2018, 03:55 PM)gijoe77 Wrote: it appears they might be (the libraries doesn't have a version number tho).

I see /irix-os/devel/developmentlibraries.tar.gz and /irix-os/devel/mipspro-74/devf_13.tar.gz on the ftp

Wonderful!  Thanks!
Best,



James Indy
zygal Offline
Indy

Posts: 14
Threads: 2
Joined: Jun 2018
Find Reply
09-27-2018, 05:30 PM
#8
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
After trying to install those two libraries, I found conflicts that seem pretty important.

It says that my irix_dev.sw.headers are incompatible with eoe.sw.base.

Most conflicts are due to the fact that they are incompatible with the eoe.sw.base.  Anyone have any issues like this before?

Looks like I was able to install nekoware gcc, however.  Is there some type of step by step to getting it from the install portion to be able to start compiling?
Best,



James Indy
(This post was last modified: 09-28-2018, 03:17 AM by zygal.)
zygal Offline
Indy

Posts: 14
Threads: 2
Joined: Jun 2018
Find Reply
09-28-2018, 02:20 AM
#9
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
The recommended bits for getting the compilers installed on 6.5.X is listed here:

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-sg2271en_us&docLocale=en_US

* 7.4 compiler execution env
* dev foundation 1.3
* development libraries
* foundation 1
* foundation 2
* overlays 1
* overlays 2
* overlays 3

You need to "open" and "open additional" each of them before "open additional" of the compiler CD itself.

You might need to substitute the right versions of your foundation and overlays for your install (the support page is more explicit, above list is what I used for 6.5.30).
(This post was last modified: 09-28-2018, 06:52 AM by mrthinlysliced.)
mrthinlysliced Offline
Octane

Posts: 71
Threads: 5
Joined: May 2018
Find Reply
09-28-2018, 06:49 AM
#10
RE: Issues installing MIPSPro, GCC, and G++ on IRIX 6.5
(09-28-2018, 06:49 AM)mrthinlysliced Wrote: The recommended bits for getting the compilers installed on 6.5.X is listed here:

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-sg2271en_us&docLocale=en_US

* 7.4 compiler execution env
* dev foundation 1.3
* development libraries
* foundation 1
* foundation 2
* overlays 1
* overlays 2
* overlays 3

You need to "open" and "open additional" each of them before "open additional" of the compiler CD itself.

You might need to substitute the right versions of your foundation and overlays for your install (the support page is more explicit, above list is what I used for 6.5.30).

This is perfect!  Thank you for the response.


As far as nekoware gcc goes, it appears like I have that installed, are there any environment variables I need to link, or commands I need to run in order to get it up and going?
Best,



James Indy
zygal Offline
Indy

Posts: 14
Threads: 2
Joined: Jun 2018
Find Reply
09-28-2018, 12:21 PM


Forum Jump:


Users browsing this thread: 1 Guest(s)