Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
help with nettle gmake check
#11
RE: help with nettle gmake check
(09-18-2018, 11:20 AM)mrthinlysliced Wrote:
(09-18-2018, 11:09 AM)gijoe77 Wrote: That reminds me - I ran into an interesting problem on my o2 with compiling openssl.  Seems some parts get compiled 64bit even if I set the the target to irix-mips3-cc and CFLAGS to "-n32".  I've been meaning on circling back on that and figuring out what's doing that, I suspect the Makefile is mucking something up

https://github.com/danielhams/didbs/blob...ixes.patch

I added an irix-mips4-cc configuration to use c99 and -n32 -mips4.

I don't remember any issues with 64 bit libs, and I've had wget happily link against this (among other things).

ok I think I figured out the issue.  I copied the openssl build dir from my Tezro (where I had built the irix64-mips4-cc target).  It appears even with a "gmake clean" and re-running configure wasn't enough to completely clean out some 64bit leftovers.  I deleted the dir and untared a fresh source tarball and it compiled fine on the o2. It did have some failed tests tho on "gmake test"...  did yours pass all tests?

here is specifically what I got for "gmake test"


Code:
( cd test; \
  mkdir -p test-runs; \
  SRCTOP=../. \
  BLDTOP=../. \
  RESULT_D=test-runs \
  PERL="perl" \
  EXE_EXT= \
  OPENSSL_ENGINES=`cd .././engines; pwd` \
  OPENSSL_DEBUG_MEMORY=on \
    perl .././test/run_tests.pl  )
../test/recipes/01-test_abort.t ............ ok   
../test/recipes/01-test_sanity.t ........... ok   
../test/recipes/01-test_symbol_presence.t .. Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/4 subtests 
../test/recipes/02-test_ordinals.t ......... ok   
../test/recipes/03-test_exdata.t ........... ok   
../test/recipes/03-test_ui.t ............... ok   
../test/recipes/04-test_pem.t .............. ok     
../test/recipes/05-test_bf.t ............... ok   
../test/recipes/05-test_cast.t ............. ok   
../test/recipes/05-test_des.t .............. ok   
../test/recipes/05-test_hmac.t ............. ok   
../test/recipes/05-test_idea.t ............. ok   
../test/recipes/05-test_md2.t .............. skipped: md2 is not supported by this OpenSSL build
../test/recipes/05-test_md4.t .............. ok   
../test/recipes/05-test_md5.t .............. ok   
../test/recipes/05-test_mdc2.t ............. ok   
../test/recipes/05-test_rand.t ............. ok   
../test/recipes/05-test_rc2.t .............. ok   
../test/recipes/05-test_rc4.t .............. ok   
../test/recipes/05-test_rc5.t .............. skipped: rc5 is not supported by this OpenSSL build
../test/recipes/05-test_rmd.t .............. ok   
../test/recipes/05-test_sha1.t ............. ok   
../test/recipes/05-test_sha256.t ........... ok   
../test/recipes/05-test_sha512.t ........... ok   
../test/recipes/05-test_wp.t ............... ok   
../test/recipes/10-test_bn.t ............... ok   
../test/recipes/10-test_exp.t .............. ok   
../test/recipes/15-test_dh.t ............... ok   
../test/recipes/15-test_dsa.t .............. ok   
../test/recipes/15-test_ec.t ............... ok   
../test/recipes/15-test_ecdsa.t ............ ok   
../test/recipes/15-test_genrsa.t ........... ok   
../test/recipes/15-test_rsa.t .............. ok   
../test/recipes/15-test_rsapss.t ........... ok   
../test/recipes/20-test_enc.t .............. ok       
../test/recipes/20-test_passwd.t ........... ok   
../test/recipes/25-test_crl.t .............. ok   
../test/recipes/25-test_d2i.t .............. ok     
../test/recipes/25-test_pkcs7.t ............ ok   
../test/recipes/25-test_req.t .............. ok   
../test/recipes/25-test_sid.t .............. ok   
../test/recipes/25-test_verify.t ........... ok       
../test/recipes/25-test_x509.t ............. ok   
../test/recipes/30-test_afalg.t ............ skipped: test_afalg not supported for this build
../test/recipes/30-test_engine.t ........... ok   
../test/recipes/30-test_evp.t .............. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 
../test/recipes/30-test_evp_extra.t ........ ok   
../test/recipes/30-test_pbelu.t ............ ok   
../test/recipes/40-test_rehash.t ........... ok   
../test/recipes/60-test_x509_store.t ....... ok   
../test/recipes/70-test_asyncio.t .......... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 
../test/recipes/70-test_bad_dtls.t ......... ok   
../test/recipes/70-test_clienthello.t ...... ok   
../test/recipes/70-test_packet.t ........... ok   
../test/recipes/70-test_sslcbcpadding.t .... ok   
../test/recipes/70-test_sslcertstatus.t .... ok   
../test/recipes/70-test_sslextension.t ..... ok   
../test/recipes/70-test_sslmessages.t ...... ok   
../test/recipes/70-test_sslrecords.t ....... ok    
../test/recipes/70-test_sslsessiontick.t ... ok    
../test/recipes/70-test_sslskewith0p.t ..... ok   
../test/recipes/70-test_sslvertol.t ........ ok   
../test/recipes/70-test_tlsextms.t ......... ok   
../test/recipes/70-test_verify_extra.t ..... ok   
../test/recipes/80-test_ca.t ............... ok   
../test/recipes/80-test_cipherlist.t ....... ok   
../test/recipes/80-test_cms.t .............. ok   
../test/recipes/80-test_ct.t ............... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 
../test/recipes/80-test_dane.t ............. ok   
../test/recipes/80-test_dtls.t ............. ok   
../test/recipes/80-test_dtlsv1listen.t ..... ok   
../test/recipes/80-test_ocsp.t ............. ok     
../test/recipes/80-test_pkcs12.t ........... ok   
../test/recipes/80-test_ssl_new.t .......... Dubious, test returned 18 (wstat 4608, 0x1200)
Failed 18/19 subtests 
../test/recipes/80-test_ssl_old.t .......... Dubious, test returned 5 (wstat 1280, 0x500)
Failed 5/7 subtests 
../test/recipes/80-test_ssl_test_ctx.t ..... ok   
../test/recipes/80-test_sslcorrupt.t ....... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 
../test/recipes/80-test_tsa.t .............. ok     
../test/recipes/80-test_x509aux.t .......... ok   
../test/recipes/90-test_async.t ............ ok   
../test/recipes/90-test_bio_enc.t .......... ok   
../test/recipes/90-test_bioprint.t ......... ok   
../test/recipes/90-test_constant_time.t .... ok   
../test/recipes/90-test_fatalerr.t ......... ok   
../test/recipes/90-test_fuzz.t ............. ok     
../test/recipes/90-test_gmdiff.t ........... ok   
../test/recipes/90-test_heartbeat.t ........ skipped: heartbeats is not supported by this OpenSSL build
../test/recipes/90-test_ige.t .............. ok   
../test/recipes/90-test_memleak.t .......... ok   
../test/recipes/90-test_p5_crpt2.t ......... ok   
../test/recipes/90-test_secmem.t ........... ok   
../test/recipes/90-test_shlibload.t ........ ok   
../test/recipes/90-test_srp.t .............. ok   
../test/recipes/90-test_sslapi.t ........... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 
../test/recipes/90-test_threads.t .......... ok   
../test/recipes/90-test_v3name.t ........... ok   

Test Summary Report
-------------------
../test/recipes/01-test_symbol_presence.t (Wstat: 512 Tests: 4 Failed: 2)
  Failed tests:  2, 4
  Non-zero exit status: 2
../test/recipes/30-test_evp.t            (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
../test/recipes/70-test_asyncio.t        (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
../test/recipes/80-test_ct.t             (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
../test/recipes/80-test_ssl_new.t        (Wstat: 4608 Tests: 19 Failed: 18)
  Failed tests:  1-18
  Non-zero exit status: 18
../test/recipes/80-test_ssl_old.t        (Wstat: 1280 Tests: 7 Failed: 5)
  Failed tests:  2-6
  Non-zero exit status: 5
../test/recipes/80-test_sslcorrupt.t     (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
../test/recipes/90-test_sslapi.t         (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=96, Tests=555, 1318 wallclock secs (17.44 usr  2.46 sys + 829.33 cusr 271.54 csys = 1120.77 CPU)
Result: FAIL
gmake[1]: *** [_tests] Error 1
gmake[1]: Leaving directory `/usr/people/develop/dev/openssl/openssl-1.1.0h'
gmake: *** [tests] Error 2
-bash-4.2$ 
(This post was last modified: 09-18-2018, 05:58 PM by gijoe77.)
gijoe77 Offline
Tezro

Posts: 349
Threads: 23
Joined: Jun 2018
Find Reply
09-18-2018, 04:06 PM
#12
RE: help with nettle gmake check
Quote:It did have some failed tests tho on "gmake test"...  did yours pass all tests?

A few failures, looks like we get the same:

https://github.com/danielhams/didbs/blob.../knownbugs

I didn't have the time to look deeper there, it was good enough for what I use it for (X11 forwarding through openssh 7-7-p1).
(This post was last modified: 09-19-2018, 06:24 AM by mrthinlysliced.)
mrthinlysliced Offline
Octane

Posts: 71
Threads: 5
Joined: May 2018
Find Reply
09-19-2018, 06:23 AM
#13
RE: help with nettle gmake check
FYI updated my openssl build, got all but one of the tests now passing.

Basically the -O2 was too optimistic (now uses -O1) and a little tweak to one of the tests to account for output format differences between linux "nm" and irix "nm".

Patch is here:

https://github.com/danielhams/didbs/blob...ixes.patch
mrthinlysliced Offline
Octane

Posts: 71
Threads: 5
Joined: May 2018
Find Reply
Yesterday, 12:28 PM


Forum Jump:


Users browsing this thread: 1 Guest(s)