I think i found an IRIX software repository
#31
Re: I think i found an IRIX software repository
Titox post_id=2253 time=1534027816 user_id=169 Wrote:There was a Date Rollup Patch from discreet to repair the epoch time error
oh so that's what that was. I'll have to be on the look out for it. I think I installed much newer version of S+W on my o2 but at some point sw_config was became 64bit binary. I had the version prior to that installed on my o2 but I still wasn't able to create a stonefs disk. I'll have to revisit this again.

Titox post_id=2253 time=1534027816 user_id=169 Wrote:BTW Stone+Wire and a Stone array is not necessary to run Spark 7.6. I got it running today with using the file system as framestore. It doesn't works with my 1600SW and I had to connect my O2 via the VGA cable.

oh nice, I'll give it another shot - it wasn't working for me when I tried it but perhaps I kept repeating some silly mistake and was unaware of it. I'll go give it a fresh start now
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
08-12-2018, 04:36 AM
#32
Re: I think i found an IRIX software repository
ok - it's all starting to come back to me now.

The S+W version that was installed with effect/spark was dying from the epoch issue, so I was not able to create a stonefs disk using that version. I took a bunch of newer versions from flame/smoke/inferno/etc prior to the 64bit builds, but I was not able to create a stonefs disk with those because I kept getting the "unlicensed" issues, and the /etc/swr-license file was of no help, so I just couldn't get past that. I have a crack or two for some older versions of S+W but I could never find those versions (i have cracks for stone 2.84 and 4.74) - do you have those handy by any chance?

I am able to get 6.1.3 and 7.1 working no problems with the filesystem specification, but 7.6 just wont work.

.rar o2_init.cfgs.rar Size: 13.67 KB  Downloads: 3



here are my Framestore configs from init.cfg:
Code:
FrameStore     /Framestore/EFFECT_6.1.3.fs, "", 2000
FrameStore     /Framestore/EFFECT_7.1.fs, "", 2000
FrameStore     /Framestore/Spark_7.6.fs, "", 2000

They are all basically the same, so I'm not sure why some work and some don't for different people. I attached the complete init.cfg's for my working 6.1.3 and 7.1, and the non-working 7.6. Can you compare them to yours? Perhaps we can both help each other here Smile


Attached Files Image(s)
   
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
08-12-2018, 06:10 AM
#33
Re: I think i found an IRIX software repository
This can be related to de Irix release. I have installed 6.5.11, which is the realse needed for effect 7.1. spark 7.6 is still installing patches so .11 seems fine.

I used 6.5.22 and 6.5.30 with effect 7.1 with no problems. Effect 6 has problems with 6.5.22 showing faults at his start related to to de Stone&Wire software. I have a file that repairs some faults but more faults are appearing.

BTW the lasts releases of spark are only for r10k cpu I don't know is they will work in my O2.



Octane2  Indigo O2 O2  1600SW   1600SW  Fuel
Titox
O2

Posts: 26
Threads: 0
Joined: May 2018
Find Reply
08-12-2018, 07:01 AM
#34
Re: I think i found an IRIX software repository
my o2 is a r10k running 6.5.22m, effect 6.1.3 has no problems for me. S+W says its version 3.0 when I launch /usr/discreet/sw/config, but under "Help/version" it says
Code:
Program:  config
Installed Driver revisions:
     disk: module 2.83   header: 2.12
     File System" <unknown>

but thats because of the epoch issue. if I set the date back it reads
Code:
File System: module 1.52     header: 1.8
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
08-12-2018, 07:32 AM
#35
Re: I think i found an IRIX software repository
Someone shared the discreet Date Rollover Patch in cgpersia some time ago, today I found it my NAS so I uploaded it to incoming. Not very useful as you can update S&W but still... for the records.



Octane2  Indigo O2 O2  1600SW   1600SW  Fuel
Titox
O2

Posts: 26
Threads: 0
Joined: May 2018
Find Reply
08-17-2018, 09:27 PM
#36
Re: I think i found an IRIX software repository
Upgrading to .22 makes no difference... upgrading to .30 the same... except seems I lost 'Helvetica for Burn' font.

But I found a trick to run all applications in my O2: I licensed the second hard disk of my r5k O2 with the /etc file trick and now I'm using it as stone framestore. effect 6.1.3, effect 7.1 and spark 7.6 are running very well with this configuration.



Octane2  Indigo O2 O2  1600SW   1600SW  Fuel
Titox
O2

Posts: 26
Threads: 0
Joined: May 2018
Find Reply
08-17-2018, 10:09 PM
#37
Re: I think i found an IRIX software repository
Titox post_id=2549 time=1534543762 user_id=169 Wrote:Upgrading to .22 makes no difference... upgrading to .30 the same... except seems I lost 'Helvetica for Burn' font.

But I found a trick to run all applications in my O2: I licensed the second hard disk of my r5k O2 with the /etc file trick and now I'm using it as stone framestore. effect 6.1.3, effect 7.1 and spark 7.6 are running very well with this configuration.

very cool. I'll have to revisit the /etc/swr-license trick. What version of S+W are you using on the o2? is it the one that comes with Effect/Spark or did you manually upgrade it to something from a different release?
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
08-18-2018, 11:36 AM
#38
Re: I think i found an IRIX software repository
It's S&W 2.6.5. I think its bundled with flame 9.5.14. I was doing a lot of tests the last week and thats the last release I installed to test with effect. I think all the releses coming with effect/spark have the date problem but with the patch it must work.



Octane2  Indigo O2 O2  1600SW   1600SW  Fuel
Titox
O2

Posts: 26
Threads: 0
Joined: May 2018
Find Reply
08-18-2018, 12:52 PM
#39
Re: I think i found an IRIX software repository
very awesome, thanks for the info
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
08-18-2018, 01:43 PM
#40
Re: I think i found an IRIX software repository
Titox post_id=2568 time=1534596775 user_id=169 Wrote:It's S&W 2.6.5. I think its bundled with flame 9.5.14. I was doing a lot of tests the last week and thats the last release I installed to test with effect. I think all the releses coming with effect/spark have the date problem but with the patch it must work.

ok I just confirmed that the S+W that ships with effect/spark is no good for o2, even with the patch. the /etc/swr-license doesn't work with that version. I installed the S+W from flame 9.5.14, and I was able to create a stone disk no problem

how are you launching spark? Do you have the framestore defined as stonefs in the config or /dev/swr00? even with the stone disk made I'm still having an issue launching spark...

edit: this is spark 7.6
gijoe77
Tezro

Posts: 469
Threads: 28
Joined: Jun 2018
Find Reply
08-21-2018, 04:24 PM


Forum Jump:


Users browsing this thread: 2 Guest(s)