Latest Threads

Forum Statistics
  • Forum posts:5,668
  • Forum threads:747
  • Members:444
  • Latest member:callahan


Posted by: Irinikus
12-01-2018, 04:09 PM
Forum: SGI Discussion
- Replies (3)

[Image: MWki91J.jpg]

[Image: 5CbVQDp.jpg]

It's pretty snazzy running at: 2@1920x1080_60! Smile

Print this item


Posted by: gijoe77
12-01-2018, 02:29 PM
Forum: IRIX/Software
- Replies (2)

I had this command saved in a nekochan PM, never occurred to me to write it down back then, and I can't seem to recall how to do it now. I'm trying to find the command that shows me the version of a shared library file, for example when I get this output:

Code:
-bash-4.2$ src/dosbox
64078:src/dosbox: rld: Fatal Error: Cannot Successfully map soname 'libtiff.so.3' version 'sgi3.7' under any of the filenames /usr/nekoware/lib/libtiff.so.3:/usr/freeware/lib32/libtiff.so.3:/usr/local/lib/libtiff.so.3:/usr/local/lib32/libtiff.so.3:/usr/lib32/libtiff.so.3:/usr/lib32/internal/libtiff.so.3:/lib32/libtiff.so.3:/opt/lib32/libtiff.so.3:/usr/nekoware/lib/libtiff.so.3.3:/usr/freeware/lib32/libtiff.so.3.3:/usr/local/lib/libtiff.so.3.3:/usr/local/lib32/libtiff.so.3.3:/usr/lib32/libtiff.so.3.3:/usr/lib32/internal/libtiff.so.3.3:/lib32/libtiff.so.3.3:/opt/lib32/libtiff.so.3.3: 
-bash-4.2$

I would like a way to verify that "version 'sgi3.7'" (or verify I hexeditied the .so file's version info correctly...)

I think it might have been a flag to elfdump, but I don't recall - here is what I was trying to do with freeware's tiff version 3.5.7:


Code:
-bash-4.2# elfdump -c  /usr/freeware/lib32/libtiff.so | grep sgi
        [     3667]: sgi1.1
        [     3684]: sgi1.0
        [     3757]: sgi1.1
        [     1104]: ld32::7.30:ld-options::-elf -_SYSTYPE_SVR4 -OPT:Olimit=0:space=ON -DEBUG:optimize_space=on -OPT:IEEE_arithmetic=1:roundoff=0:wrap_around_unsafe_opt=off -mips3 -n32 -shared -rdata_shared -check_registry ../libtiff/../port/irix/so_locations -quickstart_info -o libtiff.so -woff1009,1014,1107,1110,1116,1164,1185,1188,1204,1230,1233 -woff 85 -woff 84 -L -L/xlv1/freeware/2002.Nov/tiff/v3.5.7-root/usr/freeware/lib32 -L/xlv1/freeware/2002.Nov/tiff/v3.5.7-root/usr/freeware/lib32 -L/xlv1/freeware/2002.Nov/tiff/v3.5.7-root/usr/freeware/lib32 -L/xlv1/freeware/2002.Nov/tiff/v3.5.7-root/usr/lib32 -ljpeg -lz -dont_warn_unused -Bdynamic -lc -warn_unused -rpath /usr/freeware/lib32 -set_version sgi1.1 :
-bash-4.2# 

Print this item


Posted by: greenmeanie
12-01-2018, 11:13 AM
Forum: Beginners' Questions/Tips
- Replies (4)

hey friends, i just joined this forum. Good to see there is still some people breathing life into these machines. When friends come to my house they always ask about my machines. Like what the hell are those ugly boxes. Most have never seen or heard of them. I try to explain LOL its hard!!
Mine dont get much use anymore. Once and a while i will fire one up to show it off but most of the time they sit powered off on display. I even sort of forget all the stuff i learned back when i built them over 15 years ago.. I never kept up on them.
Lately i have been thinking about jumping back in. Finding this forum helped, knowing there are others.
Anyway, my system is nothing special but i did manage to get it all working from boxes of parts i had collected over the years..Everything i have is based on the IP22 systems running 5.2 of which i have five total, three complete which are running quite well, the other two are on the shelf. They work but i have no monitors etc for them so they are considered spares in case stuff happens to the working units. Im still using three of the big Sony 19" CRTs. One of my machines has the Galileo video options and i have both the serial and analog breakout boxes for them.
Things i want to do:
-Obtain some hard drives. The ones i have are small and only have space for system data.
-Find two more CD roms. I only have one and have to move it from machine to machine for installation work.
-Phobeus network card. Seems a hard find and interested in other options if any. I kind of doubt it.
-Max out ram. One machine has 256m the others i cant remember but its not much and i would like to max them so im looking for Kingston ram sticks or other ram that would work..
-Upgrade to 6.2 and possibly 6.5 
-Find a couple of front drive covers. i have three machines without them.
Anyway, looking forward to reading the forum!!

Print this item


Posted by: Irinikus
11-30-2018, 07:33 PM
Forum: IRIX/Software
- Replies (2)

Is it possible to network my Tezro and Octane in such a way, that I can give the Octane access to the Tezro's CD-ROM over the network, in order to carry out an IRIX install?

If so, how would this be accomplished?

Print this item


Posted by: norsparc
11-30-2018, 08:54 AM
Forum: Hardware/Triage/Repair
- Replies (4)

My Octane Octane does not start any more. There is no reaction when trying to turn it on; no sound, no leds, no fan. So I'm thinking it's a PSU problem.

Is this a known problem that has a fix? Huh 

Are there any capacitors I should try to replace first in the PSU, or should I try to change all of them to see if it will fix anything?

Print this item


Posted by: Raion
11-30-2018, 03:55 AM
Forum: Development/Porting
- Replies (5)

Okay, I'm thoroughly out of my depth here.

I've been trying to figure out on IRIX how to build a static shell (mksh and tcsh 6.20 - replacing the old and buggy shell versions) and I'm not able to for some reason.

Many of these don't have a static configure option so I've tried:

gmake SHARED=0 CC=c99 CFLAGS=-static

That will pass -static with c99 to the binary, but....

ldd tcsh
        libcurses.so  =>         /usr/lib32/libcurses.so
        libc.so.1  =>    /usr/lib32/libc.so.1

Meanwhile, I can't find with nm any dynamic symbols. 

So what should I believe here? And am I just a moron who overlooked something?

Print this item


Posted by: gijoe77
11-30-2018, 02:07 AM
Forum: Development/Porting
- Replies (3)

so I was able to compile the latest dosbox 0.74-2 via this environment:



Code:
# needed beta/neko_gmp11-5.0.2-p1.tardist
# needed libFLAC from freeware
# final link line needs -lgen after dos/libdos.a 

export CC=gcc
export CXX=g++
export CFLAGS=" -g0 -O2 -mips4"
export CXXFLAGS="-g0 -O2 -mips4"
export CPPFLAGS="-I/usr/nekoware/include/SDL"
export LDFLAGS=""
export LD_LIBRARYN32_PATH=/usr/nekoware/lib
#export ac_ct_CXX=g++

./configure -prefix=/usr/local
gmake 

the issue is dosbox dies because (dummy) CDROM support isn't configured by default:


Code:
-bash-4.2$ ./dosbox
DOSBox version 0.74-2
Copyright 2002-2018 DOSBox Team, published under GNU GPL.
---
Exit to error: Can't init SDL SDL not built with cdrom support

-bash-4.2$ 

reading up on this issue via:

https://web.archive.org/web/201412152142...ox_on_irix

it appears I need to edit the SDL_config.h file to add dummy CDROM support, I've been trying multiple things, but I can't seem to figure out the right edits.  Here are a few I tried:


Code:
-bash-4.2$ grep dosbox /usr/nekoware/include/SDL/SDL_config.h
#define SDL_CDROM_DISABLED 0 /* # Disabled to compile dosbox */
/* #undef SDL_CDROM_DUMMY /* uncomment for dosbox */
#define SDL_CDROM_DUMMY 1 /* added for dosbox */
-bash-4.2$ 


Does anyone have an idea what I'm doing wrong?

Print this item


Posted by: Raion
11-29-2018, 10:53 PM
Forum: IRIX/Software
- Replies (3)

ftp.irisware.net/ftp.irix.cc is down until further notice. Unfortunately this is why we can't have nice things:

Someone this morning compromised the master and deleted the entirety of the irix-6.5 directory. No other files appear to have been hacked, attacked or deleted.

Effective immediately, the main ftp is offline. You can check the mirrors page on the IRIX Network home page for alternative locations. 

We will not return with it until a new host and instance is online.

Print this item


Posted by: bjames
11-29-2018, 04:51 AM
Forum: Beginners' Questions/Tips
- Replies (1)

Is it possible to assign a resolution for a specific use login account with irix 6.5.28?  Typically I run 1600x1200 but I would like to be able to configure a 1280x1080 resolution for one of the user accounts.  Is this even possible?

Print this item


Posted by: GL1zdA
11-29-2018, 12:03 AM
Forum: Development/Porting
- No Replies

Does anyone have these:
Digital Media Software Development Kit v1.1
Graphics Software Development Kit
?

They were available around 2000-2001, then vanished. Tried to find them, but without any results.

Print this item